ChiliProject is not maintained anymore. Please be advised that there will be no more updates.

We do not recommend that you setup new ChiliProject instances and we urge all existing users to migrate their data to a maintained system, e.g. Redmine. We will provide a migration script later. In the meantime, you can use the instructions by Christian Daehn.

ChiliProject and gmail smtp

Added by Michael Colligan at 2011-04-18 08:54 pm

I'm very new here. I've been through various documents but none seem to get me directly in the direction I need to go to get gmail smtp working. I am a Google Apps customer. There is mention of a plugin that is required but I also read that plugin is only needed for Ruby <= 1.8.6?

I have configured config/configuration.yml with the proper credentials and settings for my Google Apps account but when I test it times out.

Thank you.


Replies (3)

RE: ChiliProject and gmail smtp - Added by Holger Just at 2011-04-18 09:33 pm

See Email_Delivery for the documentation.

If you get timeouts, make sure you are actually be able to reach

  • Make sure ChiliProject runs in the correct Rails environment (usually production).
  • Does your network function?
  • Do you have a proper internet connection?
  • Is your DNS setup correct?
  • Are any firewalls preventing you to connect to port 587 of

If you still get errors, please post the relevant your configuration.yml with passwords removed.

RE: ChiliProject and gmail smtp - Added by Michael Colligan at 2011-04-19 03:21 am

Networking is fine. Can telnet to port 587 from server. User/Pass is fine copied and pasted from configuration.yml into and logged in.

Configuration is fine. Problem is somewhere in my configuration of passenger and Rails environment. Works fine for built-in Webrick web server.

I guess I'll head off and try to solve the real problem now. I have manually tried to set production in the apache virtual host configuration as "RailsEnv production" and tried to force it in config/environment.rb by uncommenting "ENV['RAILS_ENV'] ||= 'production'". Like I said I have no clue what I'm doing. Maybe just better stick to Webrick for now since I don't see more than 10 people on the system for the foreseeable future.



RE: ChiliProject and gmail smtp - Added by Michael Colligan at 2011-04-19 03:52 am

OK, apparently solved. Added "RackEnv production" to apache virtual host configuration and all appears well. Now to understand what I just did ;-) Some day. Time to play with ChiliProject for now.