ChiliProject is not maintained anymore. Please be advised that there will be no more updates.

We do not recommend that you setup new ChiliProject instances and we urge all existing users to migrate their data to a maintained system, e.g. Redmine. We will provide a migration script later. In the meantime, you can use the instructions by Christian Daehn.

« Previous - Version 7/9 (diff) - Next » - Current version
Tom D, 2013-06-04 05:55 pm


Installation on Ubuntu 12 04 v3 (Precise Pangolin) WIP

There were some issues which I could not get around by when using ruby1.8 and nokogiri using the default packages.
Add the following ppa to fix this:
sudo apt-add-repository ppa:brightbox/ruby-ng

libreadline5-dev and libmagick9 are replaced by libreadline6-dev and libmagick++-dev

apt-get update
apt-get install apache2 ruby rubygems build-essential curl git subversion apache2-mpm-prefork mysql-server mysql-client
apt-get install libopenssl-ruby1.8 libmysqlclient-dev libpq-dev libsqlite3-dev libssl-dev zlib1g-dev libreadline6-dev libxml2-dev libapache2-mod-passenger libmagick++-dev
</per>

and then followed the guidelines for installing on ubuntu 11.04 for version [[Installation_on_Ubuntu_11_04_v2|3.x]]