ChiliProject is not maintained anymore. Please be advised that there will be no more updates.

We do not recommend that you setup new ChiliProject instances and we urge all existing users to migrate their data to a maintained system, e.g. Redmine. We will provide a migration script later. In the meantime, you can use the instructions by Christian Daehn.

Chiliproject 3.0 behind apache2 - loginproblem

Added by Konstantin Krupp at 2012-03-08 09:33 am

I recently upgraded from 2.3 to 3.0, everything worked great and it just took me 30 minutes to get all up and running again.
The chiliproject is set up behind a apache server by using ProxyPass (http://server.local/chili) what worked without any problems in 2.3.
But in 3.0 there is one tiny annoying problem, when logging in the login-button redirects to the domain server.local and doesn't use the chili prefix.
Is this a problem with my configuration or a little glitch in chiliproject?

<li id="login-menu" class="drop-down last-child">
  <a href="/chili/login" class="login">Anmelden</a> <- There is a prefix
  <input id="back_url" name="back_url" type="hidden" value="http%3A%2F%2Fserver.local%2Fprojects%2Fproject2" /> <- But its missing in the redirection

Thats what it looked like in 2.3:

<input id="back_url" name="back_url" type="hidden" value="http%3A%2F%2Fserver.local%2Fchili%2projects%2Fproject2" />

Replies (2)

RE: Chiliproject 3.0 behind apache2 - loginproblem - Added by Felix Schäfer at 2012-03-09 08:29 am

Is this when you are on the login page or is this with the login dropdown on the top right of the page? Normally the dropdown should use the exact URL you are on, if it doesn't it's a bug :-) Could you try it on a fresh install just to be sure?

RE: Chiliproject 3.0 behind apache2 - loginproblem - Added by Guillaume Bourque at 2012-03-21 06:10 pm


Our chiliproject are behind a reverse proxy called haproxy,

version 2.5 or 3.0 are working fine behind this reverse proxy.