ChiliProject is not maintained anymore. Please be advised that there will be no more updates.

We do not recommend that you setup new ChiliProject instances and we urge all existing users to migrate their data to a maintained system, e.g. Redmine. We will provide a migration script later. In the meantime, you can use the instructions by Christian Daehn.

After complete installation only get "IndexOf"

Added by Dennis L. at 2013-05-26 03:25 pm


System: Ubuntu 12.04
ChiliProject: latest version

After a complete and successful installation I want to call the main page of chiliProject first time and I only get the "IdexOf"-Page with listed content of the Folder "public".
I tried a many possibilities but nothing solved the problem.
Can anybody help me to find out what goes wrong?

Kind regards,
Dennis L.

Replies (3)

RE: After complete installation only get "IndexOf" - Added by Felix Schäfer at 2013-05-27 01:03 pm

If you use Apache and Passenger, this sounds like Passenger hasn't properly been installed and isn't loaded in Apache. apache2ctl modules should list an entry called "passenger_module".

RE: After complete installation only get "IndexOf" - Added by Dennis L. at 2013-05-27 05:53 pm


erst einmal Danke für deine Antwort.
Ja genau, ich benutze Apache und Passenger. Habe den Befehl "apache2ctl modules" (bei mir war es allerdings "apache2ctl -M") eingegeben und es wurde der Eintrag "passenger_module (shared)" unter den "Loaded Modules" aufgelistet. Sprich, Passenger ist installiert !? Vielleicht noch eine Idee woran es liegen könnte?

RE: After complete installation only get "IndexOf" - Added by Chris Dähn at 2013-05-31 12:10 am


(german) dann liegts vorauss. an deiner Apache-Konfiguration, hier muss man den Pfad für den Passenger richtig einstellen... andererseits: Hast du schonmal versucht, CP auf der Kommandozeile mit webrick zu starten (siehe Install Wiki)?

(english) I expect the problems inside the Apache config for passenger - so I would check it and before verify that the CP install runs by testing it with webrick on the command line...


PS: Could you post your Apache (sites-enabled) config?