ChiliProject is not maintained anymore. Please be advised that there will be no more updates.

We do not recommend that you setup new ChiliProject instances and we urge all existing users to migrate their data to a maintained system, e.g. Redmine. We will provide a migration script later. In the meantime, you can use the instructions by Christian Daehn.

Done bar has no filling (Bug #868)

Added by Tom Rochette at 2012-02-07 07:13 am. Updated at 2012-04-04 01:18 pm.

Status:Closed Start date:2012-02-07
Priority:Normal Due date:
Assignee:- % Done:


Category:User interface
Target version:3.1.0
Remote issue URL: Affected version:3.0.0



Couldn't check on this chiliproject if you have the same issue.

In Google Chrome (as well as Firefox 13a1), the progress bar doesn't display a filling.

A quick look with the developer tools seems to show that the style rule is overridden by another rule (see attached screenshot).

bug_progress_fill.png (97.6 kB) Tom Rochette, 2012-02-07 07:13 am

progress_closed.diff (603 Bytes) Alf Gaida, 2012-02-07 12:45 pm

Associated revisions

Revision 23864d99
Added by Michaël Rigart at 2012-03-09 06:36 pm

Fix progress bar css #868


Updated by Holger Just at 2012-02-07 09:07 am


  • Target version set to 3.1.0

Updated by Alf Gaida at 2012-02-07 12:45 pm

Set the bar filling to !important solve that for me.

Updated by Michaël Rigart at 2012-02-25 06:24 pm

Made a pull request with the changes. Adding !important only on the .closed style doesn't seem a good idea, since the other markup like percentage paragraph is also incorrect.

I added #content in front of all the progress styles so they won't inherit anymore from the general table markup.

Updated by Felix Schäfer at 2012-03-09 05:39 pm

I tested and committed Michaël's patch in 23864d9, thanks a bunch!

  • Status changed from Open to Closed

Updated by Tom Rochette at 2012-04-04 01:18 pm

Confirmed to be fixed @ 3.1.0 on Firefox 11.

Also available in: Atom PDF