ChiliProject is not maintained anymore. Please be advised that there will be no more updates.

We do not recommend that you setup new ChiliProject instances and we urge all existing users to migrate their data to a maintained system, e.g. Redmine. We will provide a migration script later. In the meantime, you can use the instructions by Christian Daehn.

Sub-sub (and deeper) issues CSS rules are overridden (Bug #911)

Added by Cory Davis at 2012-02-28 02:27 pm. Updated at 2012-03-22 12:54 am.

Status:Closed Start date:2012-02-28
Priority:Normal Due date:
Assignee:- % Done:


Category:User interface
Target version:3.1.0
Remote issue URL: Affected version:3.0.0


The tr.issue.idnt-1 to tr.issue.idnt-9 CSS rules are overridden (at least in Firefox 10.0.1) and thus do not indent sub-sub (and deeper) issues in issue lists. I solved this locally by adding !important to the 9 CSS tr.issue.idnt-n padding-left rules in application.css.

Steps to reproduce:
Create issue A.
Create issue B and set A as the parent of this issue.
Create issue C and set B as the parent of this issue.
View the issue list.

A 3 level hierarchy of issues should be displayed.

A 2 level hierarchy of issues is displayed with issue C on the same level as issue B.

ident-issues.patch (503 Bytes) Andrew Smith, 2012-03-15 01:28 am

ident-12px-inc.patch (1.5 kB) Andrew Smith, 2012-03-15 01:28 am

Related issues

duplicated by Bug #926: Task hierarchy tree structure not displayed due to CSS ca... Duplicate 2012-03-08

Associated revisions

Revision 26c847a4
Added by Felix Schäfer at 2012-03-16 12:30 am

More specific CSS #911


Updated by Felix Schäfer at 2012-03-09 05:25 pm

I'm not sure I like setting !important everywhere, that seems like a "I don't really know where the problem is but this seems to work"-fix, unfortunately, I fear my CSS-foo is not good enough for this… Could you have a look at which rules override this so we can see if it couldn't be changed? Thanks!

Updated by Andrew Smith at 2012-03-15 01:28 am

I can confirm this is happening. This line source:public/stylesheets/application.css#L1634 has a (much) higher specificity because of the use of the ID at the start of the line.

Is there a need for it to have the ID present? If it does then the idnt-X CSS lines should also have the ID prepended so that they override it as intended.

There is also very mixed padding values. The initial padding is set to 6px, the first level idnt has a padding of 0.5em (which is also 6px with the default CSS), second level idnt uses 2em (22px padding) and then the padding increases in 1.5em jumps (adding roughly 16 or 17px each time). These should really be changed to use the same amount each time. A quick test looks like adding 12px each time is a nice amount.

Updated by Felix Schäfer at 2012-03-15 11:32 pm

The CSS is dark maid enough for the moment that I wouldn't want to soften rules, I've added the extra #content rule to the issue indentations, thanks for digging that up :-)

(And note that your patch targets projects, not issues)

Committed in 26c847a

  • Status changed from Open to Closed

Updated by Andrew Smith at 2012-03-22 12:54 am

Ah, so it does (the 12px patch). Issue #926 seems to be the same issue as this but needs fixing for the "tr.project.idnt-1 td.subject" CSS as well.

Also available in: Atom PDF