ChiliProject is not maintained anymore. Please be advised that there will be no more updates.

We do not recommend that you setup new ChiliProject instances and we urge all existing users to migrate their data to a maintained system, e.g. Redmine. We will provide a migration script later. In the meantime, you can use the instructions by Christian Daehn.



To begin with, you need to decide on a ruby interpreter. ChiliProject runs best on Ruby 1.8.7 and recent variants of Ruby Enterprise Edition. For a new system you should choose one of those. The default ruby 1.8.7 is available for most platforms while other ruby interpreters might work only on certain systems. Check the respective project website for more information.

Ruby Variant ChiliProject Version
current master >= 2.6.0 2.0.0 – 2.5.0 1.1.0 — Bell, — 1.5.0
1.8 1.8.7 1.8.7 1.8.7 1.8.6, 1.8.7
1.9 1.9.2, 1.9.3 1.9.2, 1.9.3 1.9.2 not supported
2.0 not supported not supported not supported not supported
Ruby Enterprise Edition 1.8.7-xxx 1.8.7-xxx 1.8.7-xxx 1.8.7-xxx
JRuby not supported not supported not supported not supported
Rubinius not supported not supported not supported not supported
IronRuby not supported not supported not supported not supported

Warning: Ruby 1.8.6 releases before p420 contain a XSS vulnerability in webrick. See CVE-2010-0541.

Support for Ruby 1.8.6 is deprecated in the 2.x series. If you would like to use Ruby 1.8.6 with 2.x, you may need to make modification to the application code and configuration. For new setups you are advised to use a Ruby 1.8.7 compatible interpreter.

Required Ruby Libraries

In addition to the basic ruby, you need some required libraries (called rubygems) which provide some of the core functionality offered by ChiliProject. Make sure your system has the exact versions of these components installed. If not specified otherwise the exact stated versions are required.

Requirement ChiliProject Version
current master >= 3.2.0 >= 2.0.0 1.2.0 – 1.5.0 1.1.0 — Bell
rubygems >= 1.3.7, < 2.0 >= 1.3.7, < 2.0 >= 1.3.7, < 2.0 >= 1.3.7, < 2.0 >= 1.3.7, <= 1.5.3
rails (managed by bundler) (managed by bundler) (managed by bundler) 2.3.5 2.3.5
rack (managed by bundler) (managed by bundler) (managed by bundler) 1.0.1 1.0.1
rake (managed by bundler) (managed by bundler) (managed by bundler) >= 0.8.3, <= 0.8.7 >= 0.8.3, <= 0.8.7
i18n (managed by bundler) (managed by bundler) (managed by bundler) 0.4.2 0.4.2
bundler >= 1.0.14 >= 1.0.14 >= 1.0.6 (not used) (not used)


ChiliProject stores most of its working data inside a database. It supports each the following databases equally well. Choose the one that fits your needs the most.

  • MySQL 5.x
  • PostgreSQL 8.x and 9.x
  • SQLite3

(Making ChiliProject work with Oracle is not impossible, but needs some work, see rob glazers forum post for more details)

For most production deployments, you should choose one of MySQL or PostgreSQL as these are going to be much more performant. For small and sparsely used installations SQLite3 is also sufficient. To later migrate between databases vendors, you can use Taps, YamlDb, or some other database agnostic tool.

To connect ChiliProject to the chosen database you need an additional ruby gem which acts as an adapter. For some databases, there are different libraries available and used. As some of the adapters are not maintained anymore you are advised to use one of the preferred gems from the following table. Preferred database adapters are marked with a star ( ).

Requirement ChiliProject Version
current master >= 2.0.0 1.1.0 — Bell, 1.2.0, 1.3.0, 1.4.0, 1.5.0
MySQL mysql (see notes) all versions all versions all versions
mysql2 (see notes) all versions all versions all versions
ruby-mysql (pure ruby version) ??? ??? ???
PostgreSQL pg all versions all versions all versions
postgres-pr (pure ruby version) all versions all versions all versions
SQLite3 sqlite3-ruby all versions all versions all versions

The mysql gem exposes a bug in newer releases of Ruby 1.8.6. In order to make it work, you should either use a Ruby version older than or equal to 1.8.6-p388 or a mysql gem version older than or equal to 2.7. Generally, you are advised to run Ruby 1.8.7 if possible.

The mysql database adapter is only available for Ruby 1.8 as it doesn't properly observe string encoding requirements in Ruby 1.9. On Ruby 1.9, please use the mysql2 adapter instead. It provides the same functionality and is even a bit faster.

ChiliProject 1.x note: Please be aware, that Rails 2.3.5 (used in ChiliProject 1.x) has some special handling for the mysql gem. This results in limited functionality for the mysql2 gem. Therefor you will not able to properly execute the following rake tasks:

  • db:create and db:create:all
  • db:drop and db:drop:all
  • db:test:prepare

This should not be an issue in production environments. Also, these issues are fixed with ChiliProject 2.0, with Rails 2.3.12, which solves the above mentioned limitations.

Application Server

Every Ruby on Rails application runs in an environment called application server. These server components which provide the basic HTTP functionality. There are various choices which heavily depend on your operating system end environmental constraints. See the installation guide of your specific operating system for more information.

The most common choices for production deployments are Phusion Passenger (mod_rails) for Linux / UNIX which is a module for the Apache2 or Nginx webserver or Thin on Windows. Although Rails comes with a basic application server called Webrick it is only suitable for development and tests. Never use Webrick in production deployments!

Optional Components

You need some additional software depending on your use-case. For a basic ChiliProject, these components are optional, but might be required for some additional functionality.

Optional Component Description
SCM binaries ChiliProject requires the client binaries for each of the repository types you plan to use. See Repository Administration for more info.
RMagick This gem is the ruby interface to ImageMagick. It is used to export the Gantt charts to PNG format.
ruby-openid This gem is required for using the OpenID authentication. Version 2 or greater is required.