ChiliProject is not maintained anymore. Please be advised that there will be no more updates.

We do not recommend that you setup new ChiliProject instances and we urge all existing users to migrate their data to a maintained system, e.g. Redmine. We will provide a migration script later. In the meantime, you can use the instructions by Christian Daehn.

rmagick specified in the Gemfile doesn't build in Ubuntu 11.04 (Bug #458)

Added by David Kowis at 2011-06-09 04:54 pm. Updated at 2011-10-26 04:58 pm.

Status:Closed Start date:2011-06-09
Priority:Normal Due date:
Assignee:- % Done:


Target version:2.4.0
Remote issue URL: Affected version:unstable


rmagick 1.15.17 will not build in ruby 1.9.2

rmagick 2.13.1 builds just fine in ruby 1.9.2 and 1.8.7

Relevant aptitude information regarding what version of imagemagick stuff I have installed:
$ sudo aptitude show imagemagick
Automatically installed: no
Version: 7:
Depends: libbz2-1.0, libc6 (>= 2.2.5), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.2.1), libglib2.0-0 (>= 2.12.0), libgomp1 (>=
4.2.1), libice6 (>= 1:1.0.0), libjpeg62 (>= 6b1), liblcms1 (>= 1.15-1), liblqr-1-0 (>= 0.1.0), libltdl7 (>= 2.2.6b),
libmagickcore3 (>= 7:, libmagickwand3 (>= 7:, libsm6, libtiff4, libx11-6, libxext6, libxt6, zlib1g (>=
$ sudo aptitude show libmagickwand-dev
Package: libmagickwand-dev
Version: 7:
Depends: libmagickwand3 (= 7:, libmagickcore3-extra (= 7:, libmagickcore-dev (= 7:

Related issues

related to Feature #673: Require rmagick >= 2.0.0 in Gemfile Open 2011-10-26
duplicated by Bug #595: Unable to install rmagick on Ruby 1.9 Duplicate 2011-08-27


Updated by David Kowis at 2011-06-09 04:54 pm

This is using the Gemfile off the unstable branch.

Updated by Holger Just at 2011-06-09 04:55 pm

  • Category set to Libraries
  • (deleted custom field) set to unstable

Updated by Eric Davis at 2011-06-10 03:58 pm

I think there was a problem with the newer rmagick on Debian stable. I use bundle install --without=rmagick and have the Debian package installed. Would be nice to figure out what versions works, I know rmagick 2.x has some better features that I've used in a plugin.

Updated by Philipp Tessenow at 2011-07-20 01:51 am

by the way: This rmagick version refuses to install on heroku (I just ran into that). See that stackoverflow question for a stacktrace.

Updated by Andrey Mikhaylov at 2011-09-16 02:06 pm

Gemfile should be updated so that a current version of Rmagick v.2 would install.

Rmagick v.2 builds on Ruby 1.9 fine.

Updated by Felix Schäfer at 2011-10-26 04:58 pm

a17ae46 changes the default rmagick required by the Gemfile to no version, which currently resolves to rmagick 2. Additionally, there are instructions for older distros on how to add the version string to the rmagick 1 if needed.

  • Target version set to 2.4.0
  • Status changed from Open to Closed

Also available in: Atom PDF