ChiliProject is not maintained anymore. Please be advised that there will be no more updates.

We do not recommend that you setup new ChiliProject instances and we urge all existing users to migrate their data to a maintained system, e.g. Redmine. We will provide a migration script later. In the meantime, you can use the instructions by Christian Daehn.

Require rmagick >= 2.0.0 in Gemfile (Feature #673)

Added by Holger Just at 2011-10-26 08:16 pm. Updated at 2011-12-16 08:21 pm.

Status:Open Start date:2011-10-26
Priority:Normal Due date:
Assignee:- % Done:


Target version:-
Remote issue URL: Affected version:


In #458 we updated the Gemfile to allow the usage of rmagick 2 (which is required for Ruby 1.9 and on certain platforms). On the other hand, certain older distributions don't bring a sufficiently recent ImageMagick.

Nevertheless, we decided should require rmagick >= 2.0 for the 3.0.0 release to make it easier for the majority of people and to allo us to use the extended API features.

Related issues

related to Bug #458: rmagick specified in the Gemfile doesn't build in Ubuntu ... Closed 2011-06-09

Associated revisions

Revision 384a444c
Added by Jean-Philippe Lang at 2008-02-16 10:14 am

Fix grammar error in e-mail footer (closes #673).

git-svn-id: e93f8b46-1217-0410-a6f0-8f06a7374b81


Updated by Eric Davis at 2011-12-10 12:49 am

Is the only thing needed for this a change to the Gemfile?

If so I'm fine doing this. If not, then we should bump it out of 3.0.0 until it's ready.

Updated by Eric Davis at 2011-12-16 08:21 pm

Bumping out of 3.0.0 until the code is ready for this.

  • Target version deleted (3.0.0)

Also available in: Atom PDF